Degraded Performance: Issues Affecting Analytics Dashboards

Incident Report for Eltropy

Resolved

This incident has been resolved, all dashboards have been updated and are now current.
Posted Jun 23, 2026 - 23:02 PDT

Identified

We have identified an issue related to some of our Analytics Dashboards not displaying todays data.

An upstream data processing job was delayed earlier today, as a result, the downstream dashboard data refresh for certain dashboards is also delayed. To avoid potential dashboard viewing issues during active business hours, we are deferring the refresh for the affected dashboards until after business hours.
Historical data remains available, and the affected dashboards will be updated with today’s data once the scheduled refresh is completed.

We expect our data refresh to be current by 11:00 PM PDT tonight.
Posted Jun 23, 2026 - 09:08 PDT
This incident affected: Unified platform (Analytics and Reporting Services).