Voice + and AI Voice Services are down

Incident Report for Eltropy

Resolved

This incident has been resolved.
Posted Oct 20, 2025 - 04:37 PDT

Update

We are continuing to investigate this issue.
Posted Oct 20, 2025 - 04:36 PDT

Update

We are seeing partial recovery However we are still experiencing outages across POP Classic video banking East Region. We will provide another update in 60 minutes or as soon as more information becomes available.
Posted Oct 20, 2025 - 04:29 PDT

Investigating

Due to an outage in AWS services, Twilio has also been impacted, resulting in disruptions to our Voice+ and AI Voice services.
Posted Oct 20, 2025 - 03:20 PDT
This incident affected: POPi/o platform (POPi/o Video Banking Service) and Unified platform (AI Virtual Agent - Voice, Voice Service - beta).