A fix has been applied, and we are seeing services return to normal levels. We have entered a monitoring phase to ensure the continued stability of the platform across all domains.
We will provide a final "Resolved" update once we are confident in the full recovery.
Posted May 12, 2026 - 14:00 PDT
Identified
We have identified the cause of the disruption impacting Live Dashboard performance. Our engineering team is currently investigating and working on a fix to restore normal functionality as quickly as possible. We will provide our next update within 60 minutes or as soon as more information becomes available
Posted May 12, 2026 - 13:31 PDT
Update
Our team is continuing to investigate the issue impacting Live Dashboard performance.
We are actively working to identify the root cause and restore normal functionality as quickly as possible.
We will provide our next update within 60 minutes or as soon as more information becomes available.
Posted May 12, 2026 - 12:34 PDT
Investigating
We are currently investigating an issue where users may experience lag or slow performance while accessing the Live Dashboard.
Our engineering team is actively working to identify the root cause and restore normal performance as quickly as possible.
We will provide the next update within 30 minutes.
Posted May 12, 2026 - 12:07 PDT
This incident affected: Unified platform (Analytics and Reporting Services).