Issue with Payment Integration

Incident Report for Eltropy

Resolved

This incident has been resolved.
Posted Mar 06, 2026 - 09:34 PST

Identified

The issue has been identified and a fix is being implemented.
Posted Mar 06, 2026 - 08:49 PST

Investigating

We are currently investigating an issue with our payment integration where “Collect Payment” button is not functioning as expected for some customers.Our engineering team is actively working to identify the root cause and resolve the issue. We will provide further updates as more information becomes available.
Posted Mar 06, 2026 - 08:41 PST
This incident affected: Unified platform (Integration Management Service).