Analytics Dashboard Loading Issue

Incident Report for Eltropy

Resolved

This incident has been resolved.
Posted Jul 06, 2026 - 07:44 PDT

Investigating

We are currently investigating an issue where Analytics dashboards are not loading for some customers. Our engineering team is actively working to identify the root cause and restore normal service as quickly as possible.

Next Update: Within 60 minutes, or sooner if we have additional information.
Posted Jul 06, 2026 - 06:59 PDT
This incident affected: Unified platform (Analytics and Reporting Services).