Investigating Issues – Office Phone

Incident Report for Eltropy

Resolved

This incident has been resolved.
Posted Mar 09, 2026 - 12:33 PDT

Monitoring

A fix has been implemented and the system is recovering, we are continuing to monitor to ensure stability.
Posted Mar 09, 2026 - 12:04 PDT

Investigating

We are currently investigating reports of issues affecting Office Phone's. Our engineering team is triaging the root cause to determine the scope of the impact.

We will provide our next update within 30 minutes or as soon as more information becomes available.
Posted Mar 09, 2026 - 11:55 PDT
This incident affected: Unified platform (Office Phone).