Investigating Issues – Office Phone Outage

Incident Report for Eltropy

Resolved

This is a final update regarding the office phone outage. The incident is now officially resolved, and all systems are completely stable and operating normally.
Posted Mar 03, 2026 - 13:14 PST

Monitoring

We have identified and resolved the issue affecting the office phone system. All phone services are now fully restored. Our team will continue to actively monitor the system to ensure ongoing stability.
Posted Mar 03, 2026 - 13:06 PST

Investigating

We are currently investigating reports of issues affecting Office Phones. This appears to be a system wide outage and engaging our engineering team.

We will provide our next update within 60 minutes or as soon as more information becomes available.
Posted Mar 03, 2026 - 12:43 PST
This incident affected: Unified platform (Voice Service).